Jump to content

Walbro question


grumble56
 Share

Recommended Posts

Having problems with my Top80 after replacing pull start. The tick over has mysteriously gone to 6000 rpm ! Checking on miniplane usa they say both screws should be set to about 1 1/2 out. Which direction should I turn (in or out) to reduce the tickover ? Is there anything else that may cause this issue ? I have disconnected the throttle cable so its not that.

Link to comment
Share on other sites

image.thumb.png.e4f05b1297b79cd615889c6a9180adac.pngIt sounds as if the carburettor throttle butterfly is too far open. The idle adjustment screw sets the position of the buttrerfly when the hand thottle is released hence the idle rpm, adjustment anti clockwise reduces the rpm at idle.  Of course the issue could be something else; is something stopping the butterfly closing onto the idle adjustment screw?  Less likely, check for an air leak between the carburettor and engine, a lean mixture can cause increased rpm although I would expect the engine to be difficult to start.  As the problem appeared following the pull start replacement, a check of anything that may have been disturbed during that would be a good place to start.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Upcoming Events

    No upcoming events found
×
×
  • Create New...